Forum status updates

Gaming-related threads & forum issues. KEEP IT CIVIL.
User avatar
MentholMoose
Virtual-On Positive
Posts: 1976
Joined: 15 Dec 2008, 22:06
Gamertag: MentholMoose
Location: USA
Contact:

Forum status updates

Postby MentholMoose » 16 Feb 2013, 02:58

I'll use this thread to document any major changes affecting the forum. Please PM me if you notice any problems.

2013 Feb. 16
I moved the forum to a new server. In the process I also updated the forum software to the latest version.

The new server supports HTTPS so you can access the forum securely if you prefer. Besides that, it might be faster as the server has SSD storage and (probably) has more resources available.

2013 Mar. 02
I enabled SPDY on the server hosting this site. If you browse the site over HTTPS with a browser that supports SPDY (Firefox, Chrome, Opera), you may notice a speed improvement.

2013 Mar. 10
I noticed a problem with image uploading, but I fixed it by installing ImageMagick. Additionally, I updated the server to CentOS 6.4.

2013 Mar. 10
I fixed a problem preventing emails from being sent. This should now be fixed. Thanks to new member twistedsymphony for bringing this to my attention.

2013 Mar. 17
Server rebooted to update the kernel.

2013 Apr. 05
I restarted Apache to disable SPDY since I noticed certain pages weren't loading properly over HTTPS.

2013 May 13
Apache updated which required a restart.

2013 May 18
Server rebooted to update the kernel.

2013 Jun. 26
I rebooted the server to update the kernel. Also, I updated the SSL configuration in Apache to improve security.

2013 Aug. 08
I transferred the domain to a different registrar to save a few bucks.

2013 Aug. 24
Apache updated which required a restart.

2013 Oct. 19
I rebooted the server to update the kernel.

2013 Nov. 19
I updated the forum software to the latest version.

2013 Dec. 06
I upgraded the server to CentOS 6.5 which required a reboot.

2013 Dec. 21
I rebooted the server to update the kernel.

2014 Jan. 14
I rebooted the server to update the kernel.

2014 Feb. 18
It's been a year since moving the server and it is still working. Anyway today I rebooted it to update the kernel.

2014 Mar. 26
Reboot for new kernel.

2014 Apr. 09
I updated the OpenSSL packages to fix CVE-2014-0160 (the "heartbleed" bug), and also installed a new SSL key and certificate in case the old one was compromised.

2014 Jun. 07
I moved the forum to a new server. It has similar resources as the previous one but is much cheaper. The only major change is that it only has one IP address so the forum is sharing the IP with my blog. This won't be a problem unless you access the site over HTTPS with an older browser... according to Wikipedia:
As of November 2012, the only major user bases whose browsers do not support SNI appear to be users of Android 2.x (default browser), Internet Explorer on Windows XP and versions of Java before 1.7 on any operating system.
2014 Jun. 19
Reboot for kernel upgrade.

2014 Jul. 11
Reboot for kernel upgrade.

2014 Aug. 06
Updated Apache, MariaDB, and kernel (latter requiring a reboot).

2014 Aug. 16
Reboot for kernel upgrade.

2014 Aug. 27
Another reboot for a kernel upgrade.

2014 Sep. 11
Apparently some (all?) forum emails were broken. This now seems fixed.

2014 Sep. 25
Reboot for kernel upgrade.

2014 Sep. 26
Updated bash to fix the "Shellshock" bug (CVE-2014-6271 / CVE-2014-7169).

2014 Oct. 15
Reboot for kernel upgrade. Also, I have disabled SSLv3 due to the POODLE bug. This breaks compatibility for some old browsers (mainly IE6 on Windows XP), but I don't really care since the site is already broken for old browsers due to the use of SNI (see 2014 Jun. 07 update). If you cannot upgrade your browser for some strange reason, the workaround is to access the site via HTTP.

2014 Oct. 22
Reboot for kernel upgrade.

2014 Nov 05
Reboot for kernel upgrade.

2014 Nov 13
Reboot for kernel upgrade. Also I fixed a problem that was preventing emails from being sent.

2015 Jan 25
Reboot for kernel upgrade.

2015 Feb 23
Reboot for kernel upgrade.

2015 Mar 22
Reboot for kernel upgrade. Also upgraded forum software.

2015 Apr 26
Reboot for kernel upgrade.

2015 Apr 30
Reboot for kernel upgrade.

2015 Jun 09
Reboot for kernel upgrade. Also upgraded forum software.

2015 Aug 02
Reboot for server OS upgrade.

2015 Aug 03
Reboot for server reconfiguration. This was really only to confirm that some network/firewall changes I made won't cause problems during future reboots.

2015 Aug 06
Reboot for kernel upgrade.

2015 Sep 26
Reboot for kernel upgrade.

2015 Oct 19
Reboot for kernel upgrade.

2015 Nov 09
Reboot for kernel upgrade.

2015 Nov 16
Reboot for kernel upgrade.

2016 Jan 15
Reboot for kernel upgrade.

2016 Aug 16
I moved the forum to a new server. In the process I also updated the forum software to the latest version.

2016 Oct 19
Reboot for kernel upgrade.

2016 Nov 07
Reboot for kernel upgrade.

2016 Dec 16
Updated forum software.

2016 Dec 21
Reboot for kernel upgrade.

2017 Jan 21
Reboot for kernel upgrade.

2017 Mar 19
Reboot for kernel upgrade.

2017 May 23
Reboot for kernel upgrade.

2017 Jul 02
Reboot for kernel upgrade.

2017 Aug 15
Reboot for kernel upgrade.

2017 Oct 22
Reboot for kernel upgrade.
Update forum software.
Last edited by MentholMoose on 22 Oct 2017, 04:06, edited 62 times in total.
MentholMoose

User avatar
MentholMoose
Virtual-On Positive
Posts: 1976
Joined: 15 Dec 2008, 22:06
Gamertag: MentholMoose
Location: USA
Contact:

Re: Forum status updates

Postby MentholMoose » 02 Mar 2013, 21:13

I updated the OP. If anyone has any suggested improvements to the forum, let me know. Can anyone recommend any useful mods?

phpBB • Modifications - Customisation Database
MentholMoose

User avatar
MentholMoose
Virtual-On Positive
Posts: 1976
Joined: 15 Dec 2008, 22:06
Gamertag: MentholMoose
Location: USA
Contact:

Re: Forum status updates

Postby MentholMoose » 10 Mar 2013, 03:26

OP updated due to some maintenance.
MentholMoose

User avatar
MentholMoose
Virtual-On Positive
Posts: 1976
Joined: 15 Dec 2008, 22:06
Gamertag: MentholMoose
Location: USA
Contact:

Re: Forum status updates

Postby MentholMoose » 11 Mar 2013, 20:01

OP updated.
MentholMoose

User avatar
twistedsymphony
Virtual-On Positive
Posts: 211
Joined: 25 Feb 2013, 16:46
Gamertag: twistedsymphony
Location: NH, USA
Contact:

Re: Forum status updates

Postby twistedsymphony » 22 Mar 2013, 12:01

MentholMoose wrote:I updated the OP. If anyone has any suggested improvements to the forum, let me know. Can anyone recommend any useful mods?

phpBB • Modifications - Customisation Database


Not really a forum mod or feature but it might be cool to start keeping a list of all known arcades that have VO machines... Particularly non OMG machines since there are so few outside of Japan.

I know I'd like to know if there are any within a reasonable distance from me, or know where I can find one if I travel.

User avatar
MentholMoose
Virtual-On Positive
Posts: 1976
Joined: 15 Dec 2008, 22:06
Gamertag: MentholMoose
Location: USA
Contact:

Re: Forum status updates

Postby MentholMoose » 16 Aug 2016, 03:33

Forum Migration

I moved the forum to a new server. This is necessary due to the old hosting company being acquired. In the process I have upgraded the forum software as the old version will be EOL soon.

TODO
  • Selectively restore non-forum files (maybe).
  • Enable HSTS (maybe).
DONE
  • Configure new server.
  • Copy forum database.
  • Install new forum software.
  • Copy forum data.
  • Upgrade forum database.
  • Perform initial check of functionality.
  • Update DNS records.
  • Create / install new theme.
  • Restore header and background images.
  • Add redirect from main page to forum.
  • Install useful extensions.
  • Further test functionality.
Last edited by MentholMoose on 21 Dec 2016, 22:24, edited 2 times in total.
MentholMoose

User avatar
Porcupine
Virtual-On Positive
Posts: 519
Joined: 19 Jul 2012, 19:07

Re: Forum status updates

Postby Porcupine » 03 Sep 2016, 13:10

Apparently I wasn't able to see the site since the update until now. I just got some blank page. Thanks for fixing it. Was it a problem with my location, or with Firefox?

There's currently still a glitch where if I hit the back button and go prior to the login screen, or if I type oratan.com directly into the URL bar to go back to the first page, I will be automatically logged out.

User avatar
ChexGuy
Virtual-On Positive
Posts: 155
Joined: 23 Sep 2013, 18:50
Location: New York

Re: Forum status updates

Postby ChexGuy » 04 Sep 2016, 12:38

It was just the homepage not being hosted anymore. Direct links to the forum always worked.

The redirect from oratan.com doesn't keep you logged in, but if you go directly to the forum index url you'll stay logged in (index.php)
ImageImage

User avatar
Porcupine
Virtual-On Positive
Posts: 519
Joined: 19 Jul 2012, 19:07

Re: Forum status updates

Postby Porcupine » 04 Sep 2016, 13:21

Makes sense, impressive troubleshooting. I still hope the login retention can go back to the way it was before, but if not I'll live.

User avatar
MentholMoose
Virtual-On Positive
Posts: 1976
Joined: 15 Dec 2008, 22:06
Gamertag: MentholMoose
Location: USA
Contact:

Re: Forum status updates

Postby MentholMoose » 04 Sep 2016, 14:15

I think I know what's causing the login issue. If you navigate to "oratan.com" versus "www.oratan.com", the browser will see it as a different website and so the login won't be remembered. I'll try to fix it.
MentholMoose

User avatar
MentholMoose
Virtual-On Positive
Posts: 1976
Joined: 15 Dec 2008, 22:06
Gamertag: MentholMoose
Location: USA
Contact:

Re: Forum status updates

Postby MentholMoose » 04 Sep 2016, 16:46

I *think* I have all the redirects working now. Please let me know if there are still problems, and let me know the browser. I tried with Chrome 52 and IE 11 on Windows 10 x64. Thanks!!
MentholMoose

User avatar
Porcupine
Virtual-On Positive
Posts: 519
Joined: 19 Jul 2012, 19:07

Re: Forum status updates

Postby Porcupine » 07 Sep 2016, 18:54

Everything seems to work perfectly now, thanks! I'm using FireFox on Windows Vista and 10.

User avatar
MentholMoose
Virtual-On Positive
Posts: 1976
Joined: 15 Dec 2008, 22:06
Gamertag: MentholMoose
Location: USA
Contact:

Re: Forum status updates

Postby MentholMoose » 07 Sep 2016, 22:49

Fantastic, thanks for the update.
MentholMoose

User avatar
Porcupine
Virtual-On Positive
Posts: 519
Joined: 19 Jul 2012, 19:07

Re: Forum status updates

Postby Porcupine » 03 Oct 2016, 13:41

Can you make the pictures big like they used to be? The health charts are too small to read now by default.

User avatar
MentholMoose
Virtual-On Positive
Posts: 1976
Joined: 15 Dec 2008, 22:06
Gamertag: MentholMoose
Location: USA
Contact:

Re: Forum status updates

Postby MentholMoose » 04 Oct 2016, 18:56

How big? I changed it to 500 pixels. If it is too big it will mess up the layout. It is using Lightbox so clicking on the image should show the full size image.
MentholMoose

User avatar
Porcupine
Virtual-On Positive
Posts: 519
Joined: 19 Jul 2012, 19:07

Re: Forum status updates

Postby Porcupine » 05 Oct 2016, 16:55

Guess it might not be possible with the current layout. The VOOT health charts are 1409 pixels wide, the VOOM stage diagrams are 1570 pixels wide.

The 500 pixel increase doesn't seem to have taken effect, maybe it will only affect new posts? I think Firefox is still showing most images as 354 pixels wide.

User avatar
Porcupine
Virtual-On Positive
Posts: 519
Joined: 19 Jul 2012, 19:07

Re: Forum status updates

Postby Porcupine » 01 Sep 2017, 19:24

I don't know how long it's been like this but I just noticed we are all Virtual-On Postive.

User avatar
MentholMoose
Virtual-On Positive
Posts: 1976
Joined: 15 Dec 2008, 22:06
Gamertag: MentholMoose
Location: USA
Contact:

Re: Forum status updates

Postby MentholMoose » 02 Sep 2017, 01:42

It looks like it is working correctly. That title is granted at 100 posts.
MentholMoose

User avatar
Porcupine
Virtual-On Positive
Posts: 519
Joined: 19 Jul 2012, 19:07

Re: Forum status updates

Postby Porcupine » 02 Sep 2017, 14:01

Oh, I thought it might have been misspelled but I guess it's supposed to say that.

User avatar
MentholMoose
Virtual-On Positive
Posts: 1976
Joined: 15 Dec 2008, 22:06
Gamertag: MentholMoose
Location: USA
Contact:

Re: Forum status updates

Postby MentholMoose » 03 Sep 2017, 00:14

Oh I see, it is misspelled. Thanks, it's now fixed.
MentholMoose


Who is online

Users browsing this forum: No registered users and 2 guests